博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
HDU 1677 Nested Dolls
阅读量:5057 次
发布时间:2019-06-12

本文共 2351 字,大约阅读时间需要 7 分钟。

排序 + 二分:

Nested Dolls

Problem Description
Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements?
 

 

Input
On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i.
 
Output
For each test case there should be one line of output containing the minimum number of nested dolls possible.
 
Sample Input
 
4
3
20 30 40 50 30 40
4
20 30 10 10 30 20 40 50
3
10 30 20 20 30 10
4
10 10 20 30 40 50 39 51
Sample Output
 
1
2
3
2
代码:
#include<iostream>
#include<algorithm>
using namespace std;
struct Doll   //记录Doll的宽和高
{
      int w, h;
      bool operator<(Doll a)
      {
            if(w == a.w)
                  return h > a.h;
            return w < a.w;
      }
};
Doll doll[20001];
int p[20001];
int main()
{
      int t, i, n, j, l, r, m, k;
      scanf("%d", &t);
      while(t --)
      {
            scanf("%d", &n);
            for(i = 0; i < n; i ++) //输入
                  scanf("%d %d", &doll[i].w, &doll[i].h);
            sort(doll, doll + n); //排序
            m = 0;
            for(i = 0; i < n; i ++)
            {
                  l = 0;
                  r = m;
                  while(l < r)  //开始二分搜索
                  {
                        k = (l + r)/2;
                        if(p[k] >= doll[i].h)  //在p[k]后面找
                              l = k + 1;
                        else
                              r = k; //在p[k]前面找
                  }
                  p[l] = doll[i].h;  //覆盖或者新增
                  m += (l == m);  //如果没有找到,就新增一个
            }
            printf("%d\n", m);
      }
    return 0;
}

转载于:https://www.cnblogs.com/Mr_Lai/archive/2010/11/25/1887502.html

你可能感兴趣的文章
HTTP之URL的快捷方式
查看>>
满世界都是图论
查看>>
配置链路聚合中极小错误——失之毫厘谬以千里
查看>>
代码整洁
查看>>
蓝桥杯-分小组-java
查看>>
Java基础--面向对象编程1(类与对象)
查看>>
Android Toast
查看>>
iOS开发UI篇—Quartz2D使用(绘制基本图形)
查看>>
docker固定IP地址重启不变
查看>>
桌面图标修复||桌面图标不正常
查看>>
JavaScript基础(四)关于对象及JSON
查看>>
关于js sort排序方法
查看>>
JAVA面试常见问题之Redis篇
查看>>
javascript:二叉搜索树 实现
查看>>
网络爬虫Heritrix源码分析(一) 包介绍
查看>>
__int128的实现
查看>>
Problem - 1118B - Codeforces(Tanya and Candies)
查看>>
jdk1.8 api 下载
查看>>
svn 图标不显示
查看>>
getElement的几中属性介绍
查看>>